NsPro not sending email, "$errors and $error_report not defined"

3 years 4 months ago #1 by Kelvin Vanderlip
I am using NsPro 2.1 on Joomla 3.8.7 on my own server (Ubuntu 18.10). Recently, sending our newsletter has appeared to work, but then reports "0 emails sent". This is ona web site which has operated OK for about 2 years. In the Apache error log I find this, which mayo or may not be relevant:

[Sat Apr 28 01:40:17.745920 2018] [:error] [pid 19799] [client 72.203.104.113:52190] PHP Parse error: syntax error, unexpected '=' in /var/www/html/joomla/components/com_nspro/controller.php on line 638, referer: http://joomla.vanderlip.org/

[Sat Apr 28 01:41:22.682000 2018] [:error] [pid 11256] [client 72.203.104.113:52250] PHP Notice: Undefined variable: error_report in /var/www/html/joomla/components/com_nspro/controller.php on line 777, referer: http://joomla.vanderlip.org/index.php?option=com_nspro&view=nspro&layout=newsletters&Itemid=1251

Can you help me get to the bottom of this?
Thank you,
Kelvin Vanderlip
http://delamoflyers.org

Please Log in or Create an account to join the conversation.

3 years 4 months ago #2 by Christopher Mavros
Hello Kelvin and thank you for posting.
Please re-download NS Pro from Mavrosxristoforos.com, because the version you have is either corrupted, edited or just not the latest version.
I have checked both lines and there is nothing wrong in line 638 and line 777 is a comment line, so you definitely don't have the same file as I do.

Please update and let me know if you still face any problems.

Christopher Mavros
mavrosxristoforos@gmail.com
If you like our extensions, please rate us on the JED!

Please Log in or Create an account to join the conversation.

Moderators: Christopher Mavros