My Shortlist: Button doesnt show "delete" after clicking

1 month 2 weeks ago #1 by Adrian
Hello. Using the plugin and module for shortlist, and no matter what my configuration, the system seems to work when you click a Custom Block button, updating a module on the side column with Ajax. But upon refresh, the custom block buttons don't recognize which ones were already clicked.

Not sure but can you help thanks!

Please Log in or Create an account to join the conversation.

1 month 1 week ago #2 by Christopher Mavros
Hello Adrian and thank you for posting!

It is one thing to include the buttons into a certain position, and a complete different thing to make sure that they recognize the item in which they are placed.
Please tell me: Which component are you trying to include custom buttons in? Can you send me a few screenshots of the Custom Block configuration?

As a general rule, when including multiple buttons in a single page, you should set Use Current URL as Item Link and Get Item ID from URL to No, because otherwise the buttons automatically add the current page to the list, instead of the item in which they appear to be included. When you set Use Current URL as Item Link to No, a Link Selector field appears, in which you should write the CSS selector of the <a> element, so that it identifies the item using its link.

Let me know if you need further assistance!

Christopher Mavros
mavrosxristoforos@gmail.com
Serving the Joomla! community with extensions since 2008.

Please Log in or Create an account to join the conversation.

1 month 1 week ago #3 by Adrian
Here are some screenshots! I do believe I have the settings right...! I think my list prefix ID and titles are consistent across modules too.

Maybe a cache issue? I've turned it off anywhere I could find: Joomla, server, cloudflare.

This message has attachments images.
Please log in or register to see it.

Please Log in or Create an account to join the conversation.

1 month 1 week ago #4 by Adrian
Sorry I had turned off the Auto add and prefix, but it's set to "1" now and still same problem.

Please Log in or Create an account to join the conversation.

Moderators: Christopher Mavros