Possible Minor Bug Report - Mailing LIst Name Not displaying

1 week 4 days ago #1 by Chris Paschen
This is a potential VERY MINOR bug, that doesn't appear to effect functionality a bit.

How reproduce

1. Go to Mailing Lists
2. Create a new list and save
3. Click on that list in the list of mailing lists (by clicking on the name of the list)

What was expected:

The List Name should appear in the edit box.

What actually happens:

The List Name field is blank (shows the 'placeholder' text)


Again this is a very minor issue that really doesn't effect function (as long as I remember what list I was editing).

Please Log in or Create an account to join the conversation.

1 week 4 days ago #2 by Chris Paschen
This does have some more-than-minor impact on the list.

If you edit the List, and say add something in the notes field, and save (while the List Name field is left blank per this bug), then the name fields is lost - it saves as a BLANK name.

This then causes all other locations where the list name appears (i.e. in subscription forms, etc.) to loose the name and just appear blank.

So this has the potential to be more than a minor issue IF someone saves it without a name entered.

BTW ...

Joomla Ver: 3.9.19
PHP: PHP 7.3.19
MySQL: 5.5.5
NS Pro: 2.4.701

Please Log in or Create an account to join the conversation.

1 week 4 days ago #3 by Chris Paschen
OK ... one more related issue - it looks like the same thing happens on the notes field.

When you edit the list, both the name AND the notes contents are blank (not pulled in from the database) and when you save, it saves the blank, overwriting what was there with nothing.

Please Log in or Create an account to join the conversation.

1 week 1 day ago #4 by Christopher Mavros
Hi again Chris.
You are right! I can't believe how this got past me. I introduced this bug when updating the view for Joomla 4.
I have fixed it now, and also added a "Save" button (apart from the "Save & Close" button)
Please update to the latest version and you won't need to delete any of your lists.
Thanks again!

Christopher Mavros
mavrosxristoforos@gmail.com
Serving the Joomla! community with extensions since 2008.

Please Log in or Create an account to join the conversation.

6 days 5 hours ago #5 by Chris Paschen
Hey ... glad to hear your working on Joomla 4 compatibility.
(I have several custom components that I have to get migrated but I haven't found the time to get started yet).

BTW... the auto-update did not work for me, even though I have my Paypal Email address and Username entered into the Update Options tab area.
I was able to use the original link that I received when I purchased and that downloaded the current version and was able to update and the issue here (name not displaying/saving) IS resolved, so not sure if you want me to create a new issue to try to track down why my auto update is not working - although it might have something to do with the fact that my Paypal Email is not the same as the one associated on my account on your web site.

Please Log in or Create an account to join the conversation.

Moderators: Christopher Mavros