english language string in e-mail

4 months 1 week ago #1 by Benjamin
Hello,
where can I change the english language string in e-mails I receive from Rapid Contact Ex?
It tells me "You received a message from" and I would like to translate it to my native language.
I've searched the files associated with Rapid Contact Ex but couldn't find the text string to change it.

Any help is appreciated.

Please Log in or Create an account to join the conversation.

4 months 1 week ago #2 by Christopher Mavros
Hello Benjamin. Thank you for posting.
I'm glad you asked.

This string can be changed using the language ini files.
It is located in file components/com_rapidcontactex/views/rpxform/tmpl/default_email_header.php since the last version, which can also be overwritten by creating a template override to templates/your_template/com_rapidcontactex/rpxform/default_email_header.php

So, there are two ways you can change that string. You can either completely remove it by creating a template override or change it to what you want in the php file, or change the existing translatable string using the language ini files.

Here is a help base article that explains all about language ini files and where to find strings in Joomla extensions:
https://mavrosxristoforos.com/help-base/33-changing-texts-in-joomla-extensions

Thanks again!

Christopher Mavros
mavrosxristoforos@gmail.com
Serving the Joomla! community with extensions since 2008.

Please Log in or Create an account to join the conversation.

4 months 1 week ago #3 by Benjamin
Your response makes sense and is well explained.
I created a template override and changed the text string inside that but it doesn't change the text string in the e-mail.
I also replaced the text string in the components folder of joomla as a second option. Same result.
Cache is disabled both in joomla and google chrome, so that's not the error. Can you imagine what could be wrong?

Please Log in or Create an account to join the conversation.

4 months 1 week ago #4 by Christopher Mavros
Can you make other changes in the template override to check if that works at all?
If it doesn't, you can always switch to just changing the language ini file (not the components folder, as that will be reset the next time you update the component).

Please try these two options and let me know what works.

Christopher Mavros
mavrosxristoforos@gmail.com
Serving the Joomla! community with extensions since 2008.

Please Log in or Create an account to join the conversation.

4 months 1 week ago #5 by Benjamin
language override works. Thanks again!

Please Log in or Create an account to join the conversation.

Moderators: Christopher Mavros