Component Rapid Contact EX Field Manager

5 years 2 months ago #1 by Michelle HEBERT
Component Rapid Contact EX Field Manager was created by Michelle HEBERT
Hi,

I am French, so please excuse my English !

I bought and installed mod and com rapid contact EX.
I tried to make my first simple contact form, but the result is not really what I expected.
Where can I specify the size of a Textbox or Textarea ? Currently there are very small (see the picture attached)

I wish I could have an example of what must be entered to get a simple contact form as the one shown on your site
Thanks for your help
Michelle

Please Log in or Create an account to join the conversation.

5 years 2 months ago #2 by Christopher Mavros
Replied by Christopher Mavros on topic Component Rapid Contact EX Field Manager
Hello Michelle and thank you for posting.
Many times sizes are adjusted by your template.
I cannot find the attached image, but still:
1) Please try to change the sizes using the Component Options in the Field Manager (button Options on the top right).
2) If that doesn't work, you can set your own sizes using the following CSS:

.rpx_field input { width: 100px; }
.rpx_field textarea { width: 150px; }

You can also make them relative to their container, like so:

.rpx_field input { width: 50%; }
.rpx_field textarea { width: 80%; }

The above CSS snippets can be added either in components/com_rapidcontactex/rpx.css or in your template CSS file.

Thanks again.

Christopher Mavros
mavrosxristoforos@gmail.com
If you like our extensions, please rate us on the JED!
The following user(s) said Thank You: Michelle HEBERT

Please Log in or Create an account to join the conversation.

5 years 2 months ago - 5 years 2 months ago #3 by Michelle HEBERT
Replied by Michelle HEBERT on topic Component Rapid Contact EX Field Manager

Hello Michelle and thank you for posting.
Many times sizes are adjusted by your template.
I cannot find the attached image, but still:
1) Please try to change the sizes using the Component Options in the Field Manager (button Options on the top right).
2) If that doesn't work, you can set your own sizes using the following CSS:

.rpx_field input { width: 100px; }
.rpx_field textarea { width: 150px; }

You can also make them relative to their container, like so:

.rpx_field input { width: 50%; }
.rpx_field textarea { width: 80%; }

The above CSS snippets can be added either in components/com_rapidcontactex/rpx.css or in your template CSS file.

Thanks again.

Thanks for your reply.
I cannot find the options button on the top right : see capture1.jpg
I do not know where I could find components/com_rapidcontactex/rpx.css





My SIte : http://miklod.net
Menu item "Nous contacter"
>>> it does not work properly, so I returen to my previous mod Rapid Contact, waiting to solve my problem.

Regards,
Michelle

This message has attachments images.
Please log in or register to see it.

Please Log in or Create an account to join the conversation.

5 years 2 months ago #4 by Christopher Mavros
Replied by Christopher Mavros on topic Component Rapid Contact EX Field Manager
Hello again.

You can find the file components/com_rapidcontactex/rpx.css using a File Manager from your host control panel (cPanel usually).
Although, please first do this:
Go to the menu item options and switch "Label Position" to "As Placeholder".
I think you will like this look much better.

Now, the Options button is right there on the top right of the screenshot you attached, but since it is in French, it says "Param├Ętres".

Thanks again.

Christopher Mavros
mavrosxristoforos@gmail.com
If you like our extensions, please rate us on the JED!
The following user(s) said Thank You: Michelle HEBERT

Please Log in or Create an account to join the conversation.

5 years 2 months ago - 5 years 2 months ago #5 by Michelle HEBERT
Replied by Michelle HEBERT on topic Component Rapid Contact EX Field Manager

Hello again.

You can find the file components/com_rapidcontactex/rpx.css using a File Manager from your host control panel (cPanel usually).
Although, please first do this:
Go to the menu item options and switch "Label Position" to "As Placeholder".
I think you will like this look much better.

Now, the Options button is right there on the top right of the screenshot you attached, but since it is in French, it says "Param├Ętres".

Thanks again.

Hi,

Thanks for your reply, it helps, and I think it will be all set very soon.
So I when to the menu and switch to "as placeholder" and it looks much better :)
I click on the options button and set a few parameters for the field widths
I made a first attempt, filling the required fields :



As you can see I put a valid address mail, a name, subject and one line of text in the message area/
I filled the "anti-spam" answer 24 (how many hours in a day ?)
Then I hit Enter and this is what I get :



I put back my regular Rapid Contact module, waiting to solve my settings of Rapid Contact EX

Thanks again for your help.
Michelle

This message has attachments images.
Please log in or register to see it.

Please Log in or Create an account to join the conversation.

5 years 2 months ago #6 by Christopher Mavros
Replied by Christopher Mavros on topic Component Rapid Contact EX Field Manager
Hi again Michelle.
This happens if you don't write names for your fields in the Field Manager.
Rapid Contact Ex prints the fields using their names, and if they are not unique, two field posted values are mixed, yielding the result you showed me.
Please name your fields correctly and it should work fine.

Thanks again.

Christopher Mavros
mavrosxristoforos@gmail.com
If you like our extensions, please rate us on the JED!

Please Log in or Create an account to join the conversation.

Moderators: Christopher Mavros