How to create a survey in order to consensualize about several proposals?

3 months 1 day ago #1 by Clemens
Actually  am creating a survey, where people take part in "systemic consensuation". Consensuation is a real basic democratic tool to let a group of people decide about all kinds of proposals. In SimpleQuiz I use the survey mode and each proposal is presented in a "quiz question". The participants will vote about their resistance to each proposal, scaled from 0 = full acceptance and 10 = maximum against it and all shades between.
In my first test, sometimes a "Zero" of an item is transmitted by SimpleQuiz as a valid answer and sometimes it is not. Of course, I have deactivated the "mandatory ckeckbox" for each item. After several times of trying, there will be no values transmitted to the admin email address, although the user's name its email and the items are transmitted.
Are there some difficulties with this kind of survey? Are there some special settings required?

SimpleQuiz is running here on a Joomla 3.10.10 system, running old PHP 7.4

Please Log in or Create an account to join the conversation.

3 months 1 day ago #2 by Christopher Mavros
I can't see any reason that this may not work.
I just tested it in both J3 and J4, and the results came in as expected.
Can you possibly check for template overrides, or any other reason that SimpleQuiz may not work as expected?

Christopher Mavros
mavrosxristoforos@gmail.com
If you like our extensions, please rate us on the JED!

Please Log in or Create an account to join the conversation.

3 months 1 day ago #3 by Clemens
I am sure, that there is no template override. And further there is a similar issue with the "complete text", which does not show up any more. Nearly at the same time with my experiments with SQ, the problem with the "complete text" and with the missing results of the surveys came up. But I do not know, which settings I have changed, to urge these both problems.

On my old Joomla 3.10.10 website, I am using a very old template, called JYAML. I kept this since about 12 years because I am familiar with this. I will have to redesign this website completely when changing it to Joomla 4.
On my Joomla 4 test site, I am using a non modified template, which is very similar to Cassiopeia.

But my survey / consensualization did work at first and then suddenly showed up these two problems. Therefore I think, the problem does not arise from a conflict in template override.

It is strange, that both installations show up the same problems. But I cannot find any wrong or disturbing setting for my survey.
It did nothing change, setting the questions / proposals to a value range from 1 to 10 instead of 0 to 10.
It did nothing change, setting the questions / proposals to mandatory or not mandatory.

 

Please Log in or Create an account to join the conversation.

3 months 22 hours ago #4 by Christopher Mavros
As per your other post, please send me a temporary administrator account via email, to inspect this situation.
Thanks again.

Christopher Mavros
mavrosxristoforos@gmail.com
If you like our extensions, please rate us on the JED!

Please Log in or Create an account to join the conversation.

3 months 20 hours ago #5 by Clemens
Yes, you will get the credentials for both websites this evening. Thank you for your engagement and your support!

Please Log in or Create an account to join the conversation.

3 months 4 hours ago #6 by Christopher Mavros
After checking, the problem was that the "Show given answers" in the Quiz layout tab of the Quiz was set to No.
This has to be yes to receive the given answers.

Christopher Mavros
mavrosxristoforos@gmail.com
If you like our extensions, please rate us on the JED!

Please Log in or Create an account to join the conversation.

Moderators: Christopher Mavros