Error appears when 'new question' is selected

3 years 2 months ago #1 by Ben van Wetten
Error appears when 'new question' is selected was created by Ben van Wetten
Hi Christopher,

Just renewed my subscription with SimpleQuiz version 1.8.457
When I try to create a new question (pressing 'new'), an error message appears, stating:

"Call to a member function setQuery() on null"

As far as I can see, all other functions are fine...

I can only return to the control panel from there.
Joomla 3.8.10
SimpleQuiz 1.8.457
PHP 7.0
MySQL 5.0.10

Please Log in or Create an account to join the conversation.

3 years 2 months ago #2 by Christopher Mavros
Replied by Christopher Mavros on topic Error appears when 'new question' is selected
Hello Ben and thank you very much for your renewal.
I cannot see why this would happen.

Can you send me a temporary super admin account access at mavrosxristoforos@gmail.com?
Or if you don't want to, please enable Joomla Debug mode from System > Global Configuration > System > Debug System (Switch to Yes) and send me a screenshot of the call stack.

Thanks again.

Christopher Mavros
mavrosxristoforos@gmail.com
If you like our extensions, please rate us on the JED!

Please Log in or Create an account to join the conversation.

3 years 2 months ago #3 by Ben van Wetten
Replied by Ben van Wetten on topic Error appears when 'new question' is selected
Hi Christopher,

Just now sent you login details for the admin-part of the website.
Next to the 'call stack' this morning, I hope this will lead to a solution.

The error seems to appear only on second and later attempts to add a 'new question. On the first attempt it seems to work fine.
This lead me to think that a cache-memory problem was the culprit. But temporarily deleting the 'cachecleaner' did not solve this.

Hope you can find your way,
Thanks for your time,
Ben

Please Log in or Create an account to join the conversation.

3 years 2 months ago #4 by Christopher Mavros
Replied by Christopher Mavros on topic Error appears when 'new question' is selected
Thank you Ben. All provided information made it very easy to track the bug and fix it.
I have installed the fixed version directly to your website and I will release the fix later today.
Thank you again.

Christopher Mavros
mavrosxristoforos@gmail.com
If you like our extensions, please rate us on the JED!

Please Log in or Create an account to join the conversation.

3 years 2 months ago #5 by Ben van Wetten
Replied by Ben van Wetten on topic Error appears when 'new question' is selected
Thank you so much, Christopher,

Your help is very much appreciated.
Although I am not aware of the actual problem, it has been solved by your implementation of the next version.

Great job, you have my support forever...
Ben

Please Log in or Create an account to join the conversation.

3 years 2 months ago #6 by Christopher Mavros
Replied by Christopher Mavros on topic Error appears when 'new question' is selected
Thank you Ben.
It was a silly mistake, probably made by re-organizing the code for maintenance, and the database handle was not being retrieved for use, so the setQuery function was executed on a null variable.

Christopher Mavros
mavrosxristoforos@gmail.com
If you like our extensions, please rate us on the JED!
The following user(s) said Thank You: Ben van Wetten

Please Log in or Create an account to join the conversation.

Moderators: Christopher Mavros