No "after quiz" text shows up. And "name" inserted in email is not replaced

3 months 1 day ago #1 by Clemens
Several times, I have checked the settings, but although everything seems to be set right, no "after quiz" text shows up on the Joomla page. The page with SimpleQuiz is opened via a menu item, which is connected with one defined quiz.

Further I have put [name] within the email text, which will be sent to the user of the quiz, after he has submitted it. The field [name] shows up in the email is not replaced by the name, the user has typed in before pushing the submit button.

This behaviour is the same on Joomla 3.10.10 and Joomla 4.x latest. Both Joomla installations are running on PHP 7.4.

Please Log in or Create an account to join the conversation.

3 months 1 day ago #2 by Christopher Mavros
Is this a quiz or a survey? If this is a quiz, the Complete Text will only appear if the amount of correct answers is reached. Otherwise, the fail text is shown.

At the moment, the Email Pre-Text to the user is not filtered, so you can't write [name] in it.
If you want, we can implement this.

Thanks again.

Christopher Mavros
mavrosxristoforos@gmail.com
If you like our extensions, please rate us on the JED!

Please Log in or Create an account to join the conversation.

3 months 1 day ago #3 by Clemens
Sorry that I have forgotten to mention: It is a survey. And after the very first experiments with SQ, the "after text" always showed up, after completing the survey. I don't know, what I have changed, so that the after-text will not show up any more.
This effect is on both installations, on Joomla 3.10.10 as well as on Joomla 4.x

Perhaps something is broken now on both installations ( Joomla 3.10.10 as well as on Joomla 4.x) because there is also another problem (other thread), where I suddenly do not get any results from the survey, neither in the email to admin, nor in the backend when looking into results listing.

Concerning [name] in the email text: It is a simple nice to have, but it is not really necessary for me. I thought, filtering for that term would be active.

Please Log in or Create an account to join the conversation.

3 months 21 hours ago #4 by Christopher Mavros
I meant if it is correctly set as a Survey in the Quiz edit page. Please double check.

Can you please send me an email with a temporary administrator account to see the set-up in either of these installations?
Please make sure to re-install SimpleQuiz, because sometimes in Joomla the installations don't complete successfully.

I have added the ability to filter [name] and [email] in the Email Pre Text to the user, and it will be included in our next release.
Thanks again.

Christopher Mavros
mavrosxristoforos@gmail.com
If you like our extensions, please rate us on the JED!

Please Log in or Create an account to join the conversation.

3 months 4 hours ago #5 by Christopher Mavros
After checking, the "Show Complete/Fail Text" option of the Quiz was set to "No". This may have happened automatically due to an incomplete update.
I have switched it to Yes, and it now shows up normally.

Christopher Mavros
mavrosxristoforos@gmail.com
If you like our extensions, please rate us on the JED!

Please Log in or Create an account to join the conversation.

2 months 4 weeks ago #6 by Clemens
Yes this is strange as I think, it would have been in my focus. Thank you for your engagement and your quick replies!
My SQ is now in productive mode on my website. Everything is nice (...but I could not switch to use the German language files, I have translated and put in via ftp. (See other thread https://mavrosxristoforos.com/support/forums/simplequiz-forum/379-how-to-insert-translations-no-language-file#1315)

Please Log in or Create an account to join the conversation.

Moderators: Christopher Mavros